What’s Vulnerable › Vulnerabilities
CVE-2020-11030: Cross-site scripting (XSS) in Search block in WordPress
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-30 · updated 2026-06-17
- Weakness: CWE-707
Description
In affected versions of WordPress, a special payload can be crafted that can lead to scripts getting executed within the search block of the block editor. This requires an authenticated user with the ability to add content. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).
Affected products
- Debian Linux: 9.0, 10.0
- WordPress: before 5.4.1 — fixed in 5.4.1
How to fix
Upgrade to a fixed version: WordPress 5.4.1. Check the vendor advisory for mitigations.
References
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-vccm-6gmc-qhjh
- https://wordpress.org/support/wordpress-version/version-5-4-1/#security-updates
- https://www.debian.org/security/2020/dsa-4677
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-vccm-6gmc-qhjh
- https://wordpress.org/support/wordpress-version/version-5-4-1/#security-updates
- https://www.debian.org/security/2020/dsa-4677
Get alerted when CVE-2020-11030 or the next vulnerability affects your stack