What’s Vulnerable › Vulnerabilities
CVE-2020-11031: Insecure encryption algorithm in GLPI
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-23 · updated 2026-06-17
- Weakness: CWE-327
Description
In GLPI before version 9.5.0, the encryption algorithm used is insecure. The security of the data encrypted relies on the password used, if a user sets a weak/predictable password, an attacker could decrypt data. This is fixed in version 9.5.0 by using a more secure encryption library. The library chosen is sodium.
Affected products
- glpi-project glpi: before 9.5.0 — fixed in 9.5.0
How to fix
Upgrade to a fixed version: glpi-project glpi 9.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/commit/f1ae6c8481e5c19a6f1801a5548cada45702e01a#diff-b5d0ee8c97c7abd7e3fa29b9a27d1780
- https://github.com/glpi-project/glpi/security/advisories/GHSA-7xwm-4vjr-jvqh
- https://github.com/glpi-project/glpi/commit/f1ae6c8481e5c19a6f1801a5548cada45702e01a#diff-b5d0ee8c97c7abd7e3fa29b9a27d1780
- https://github.com/glpi-project/glpi/security/advisories/GHSA-7xwm-4vjr-jvqh
Get alerted when CVE-2020-11031 or the next vulnerability affects your stack