What’s Vulnerable › Vulnerabilities
CVE-2020-11041: Improper Validation of Array Index in FreeRDP
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-29 · updated 2026-06-17
- Weakness: CWE-129
Description
In FreeRDP less than or equal to 2.0.0, an outside controlled array index is used unchecked for data used as configuration for sound backend (alsa, oss, pulse, ...). The most likely outcome is a crash of the client instance followed by no or distorted sound or a session disconnect. If a user cannot upgrade to the patched version, a workaround is to disable sound for the session. This has been patched in 2.1.0.
Affected products
- Debian Linux: 10.0
- FreeRDP: before 2.1.0 — fixed in 2.1.0
- openSUSE Leap: 15.1
How to fix
Upgrade to a fixed version: FreeRDP 2.1.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00080.html
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-w67c-26c4-2h9w
- https://lists.debian.org/debian-lts-announce/2023/10/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00080.html
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-w67c-26c4-2h9w
- https://lists.debian.org/debian-lts-announce/2023/10/msg00008.html
Get alerted when CVE-2020-11041 or the next vulnerability affects your stack