What’s Vulnerable › Vulnerabilities
CVE-2020-11042: Out-of-bounds Read in FreeRDP
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-05-07 · updated 2026-06-17
- Weakness: CWE-125
Description
In FreeRDP greater than 1.1 and before 2.0.0, there is an out-of-bounds read in update_read_icon_info. It allows reading a attacker-defined amount of client memory (32bit unsigned -> 4GB) to an intermediate buffer. This can be used to crash the client or store information for later retrieval. This has been patched in 2.0.0.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.10, 20.04
- Debian Linux: 9.0, 10.0
- FreeRDP: from 1.1.0 (excl.) before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: FreeRDP 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/FreeRDP/FreeRDP/commit/6b2bc41935e53b0034fe5948aeeab4f32e80f30f
- https://github.com/FreeRDP/FreeRDP/issues/6010
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-9jp6-5vf2-cx2q
- https://lists.debian.org/debian-lts-announce/2020/08/msg00054.html
- https://lists.debian.org/debian-lts-announce/2023/10/msg00008.html
- https://usn.ubuntu.com/4379-1/
- https://usn.ubuntu.com/4382-1/
- https://github.com/FreeRDP/FreeRDP/commit/6b2bc41935e53b0034fe5948aeeab4f32e80f30f
- https://github.com/FreeRDP/FreeRDP/issues/6010
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-9jp6-5vf2-cx2q
- https://lists.debian.org/debian-lts-announce/2020/08/msg00054.html
- https://lists.debian.org/debian-lts-announce/2023/10/msg00008.html
Get alerted when CVE-2020-11042 or the next vulnerability affects your stack