What’s Vulnerable › Vulnerabilities
CVE-2020-11046: Improper Restriction of Operations within the Bounds of a Memory Buffer in FreeRDP
- Severity: low (CVSS 2.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-07 · updated 2026-06-17
- Weakness: CWE-119
Description
In FreeRDP after 1.0 and before 2.0.0, there is a stream out-of-bounds seek in update_read_synchronize that could lead to a later out-of-bounds read.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.10, 20.04
- Debian Linux: 9.0, 10.0
- FreeRDP: from 1.0.0 (excl.) before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: FreeRDP 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/FreeRDP/FreeRDP/commit/ed53cd148f43cbab905eaa0f5308c2bf3c48cc37
- https://github.com/FreeRDP/FreeRDP/issues/6006
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-hx48-wmmm-mr5q
- https://lists.debian.org/debian-lts-announce/2020/08/msg00054.html
- https://lists.debian.org/debian-lts-announce/2023/10/msg00008.html
- https://usn.ubuntu.com/4379-1/
- https://usn.ubuntu.com/4382-1/
- https://github.com/FreeRDP/FreeRDP/commit/ed53cd148f43cbab905eaa0f5308c2bf3c48cc37
- https://github.com/FreeRDP/FreeRDP/issues/6006
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-hx48-wmmm-mr5q
- https://lists.debian.org/debian-lts-announce/2020/08/msg00054.html
- https://lists.debian.org/debian-lts-announce/2023/10/msg00008.html
Get alerted when CVE-2020-11046 or the next vulnerability affects your stack