What’s Vulnerable › Vulnerabilities
CVE-2020-11052: Improper Restriction of Excessive Authentication Attempts in Sorcery
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-07 · updated 2026-06-17
- Weakness: CWE-307
Description
In Sorcery before 0.15.0, there is a brute force vulnerability when using password authentication via Sorcery. The brute force protection submodule will prevent a brute force attack for the defined lockout period, but once expired, protection will not be re-enabled until a user or malicious actor logs in successfully. This does not affect users that do not use the built-in brute force protection submodule, nor users that use permanent account lockout. This has been patched in 0.15.0.
Affected products
- Sorcery: before 0.15.0 — fixed in 0.15.0
How to fix
Upgrade to a fixed version: Sorcery 0.15.0. Check the vendor advisory for mitigations.
References
- https://github.com/Sorcery/sorcery/commit/0f116d223826895a73b12492f17486e5d54ab7a7
- https://github.com/Sorcery/sorcery/issues/231
- https://github.com/Sorcery/sorcery/pull/235
- https://github.com/Sorcery/sorcery/security/advisories/GHSA-jc8m-cxhj-668x
- https://github.com/Sorcery/sorcery/commit/0f116d223826895a73b12492f17486e5d54ab7a7
- https://github.com/Sorcery/sorcery/issues/231
- https://github.com/Sorcery/sorcery/pull/235
- https://github.com/Sorcery/sorcery/security/advisories/GHSA-jc8m-cxhj-668x
Get alerted when CVE-2020-11052 or the next vulnerability affects your stack