What’s Vulnerable › Vulnerabilities
CVE-2020-11055: Cross-site Scripting in BookStack
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-07 · updated 2026-06-17
- Weakness: CWE-79
Description
In BookStack greater than or equal to 0.18.0 and less than 0.29.2, there is an XSS vulnerability in comment creation. A user with permission to create comments could POST HTML directly to the system to be saved in a comment, which would then be executed/displayed to others users viewing the comment. Through this vulnerability custom JavaScript code could be injected and therefore ran on other user machines. This most impacts scenarios where not-trusted users are given permission to create comments. This has been fixed in 0.29.2.
Affected products
- bookstackapp/bookstack: from 0.18.0 before 0.29.2 — fixed in 0.29.2
How to fix
Upgrade to a fixed version: bookstackapp/bookstack 0.29.2. Check the vendor advisory for mitigations.
References
- http://jvn.jp/en/jp/JVN41035278/index.html
- https://bookstackapp.com/blog/beta-release-v0-29-2/
- https://github.com/BookStackApp/BookStack/releases/tag/v0.29.2
- https://github.com/BookStackApp/BookStack/security/advisories/GHSA-5vf7-q87h-pg6w
- http://jvn.jp/en/jp/JVN41035278/index.html
- https://bookstackapp.com/blog/beta-release-v0-29-2/
- https://github.com/BookStackApp/BookStack/releases/tag/v0.29.2
- https://github.com/BookStackApp/BookStack/security/advisories/GHSA-5vf7-q87h-pg6w
Get alerted when CVE-2020-11055 or the next vulnerability affects your stack