What’s Vulnerable › Vulnerabilities
CVE-2020-11058: Improper Restriction of Operations within the Bounds of a Memory Buffer in FreeRDP
- Severity: low (CVSS 2.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-12 · updated 2026-06-17
- Weakness: CWE-119
Description
In FreeRDP after 1.1 and before 2.0.0, a stream out-of-bounds seek in rdp_read_font_capability_set could lead to a later out-of-bounds read. As a result, a manipulated client or server might force a disconnect due to an invalid data read. This has been fixed in 2.0.0.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.10, 20.04
- Debian Linux: 9.0, 10.0
- FreeRDP: from 1.1.0 (excl.) through 2.0.0
References
- https://github.com/FreeRDP/FreeRDP/commit/3627aaf7d289315b614a584afb388f04abfb5bbf
- https://github.com/FreeRDP/FreeRDP/issues/6011
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-wjg2-2f82-466g
- https://lists.debian.org/debian-lts-announce/2020/08/msg00054.html
- https://lists.debian.org/debian-lts-announce/2023/10/msg00008.html
- https://usn.ubuntu.com/4379-1/
- https://usn.ubuntu.com/4382-1/
- https://github.com/FreeRDP/FreeRDP/commit/3627aaf7d289315b614a584afb388f04abfb5bbf
- https://github.com/FreeRDP/FreeRDP/issues/6011
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-wjg2-2f82-466g
- https://lists.debian.org/debian-lts-announce/2020/08/msg00054.html
- https://lists.debian.org/debian-lts-announce/2023/10/msg00008.html
Get alerted when CVE-2020-11058 or the next vulnerability affects your stack