What’s Vulnerable › Vulnerabilities
CVE-2020-11080: Denial of service in nghttp2
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-03 · updated 2026-06-17
- Weakness: CWE-707
Description
In nghttp2 before version 1.41.0, the overly large HTTP/2 SETTINGS frame payload causes denial of service. The proof of concept attack involves a malicious client constructing a SETTINGS frame with a length of 14,400 bytes (2400 individual settings entries) over and over again. The attack causes the CPU to spike at 100%. nghttp2 v1.41.0 fixes this vulnerability. There is a workaround to this vulnerability. Implement nghttp2_on_frame_recv_callback callback, and if received frame is SETTINGS frame and the number of settings entries are large (e.g., > 32), then drop the connection.
Affected products
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 31, 33
- nghttp2: before 1.41.0 — fixed in 1.41.0
- Node.js: from 10.0.0 through 10.12.0; from 10.13.0 before 10.21.0; from 12.0.0 through 12.12.0; from 12.13.0 before 12.18.0; from 14.0.0 through 14.4.0 — fixed in 10.21.0, 12.18.0
- openSUSE Leap: 15.1
- Oracle Banking Extensibility Workbench: 14.3.0, 14.4.0
- Oracle Blockchain Platform: before 21.1.2 — fixed in 21.1.2
- Oracle Corporation Enterprise Communications Broker: 3.1.0, 3.2.0
- Oracle Corporation GraalVM Enterprise Edition: 19.3.2, 20.1.0
- MySQL Server: from 7.3.0 through 7.3.30; from 7.4.0 through 7.4.29; from 7.5.0 through 7.5.19; from 7.6.0 through 7.6.15; from 8.0.0 through 8.0.21
How to fix
Upgrade to a fixed version: nghttp2 1.41.0; Node.js 10.21.0, 12.18.0; Oracle Blockchain Platform 21.1.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-06/msg00024.html
- https://github.com/nghttp2/nghttp2/commit/336a98feb0d56b9ac54e12736b18785c27f75090
- https://github.com/nghttp2/nghttp2/commit/f8da73bd042f810f34d19f9eae02b46d870af394
- https://github.com/nghttp2/nghttp2/security/advisories/GHSA-q5wr-xfw9-q7xr
- https://lists.debian.org/debian-lts-announce/2021/10/msg00011.html
- https://lists.debian.org/debian-lts-announce/2023/10/msg00023.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4OOYAMJVLLCLXDTHW3V5UXNULZBBK4O6/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/AAC2AA36OTRHKSVM5OV7TTVB3CZIGEFL/
- https://www.debian.org/security/2020/dsa-4696
- https://www.oracle.com//security-alerts/cpujul2021.html
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://www.oracle.com/security-alerts/cpujan2021.html
Get alerted when CVE-2020-11080 or the next vulnerability affects your stack