What’s Vulnerable › Vulnerabilities
CVE-2020-11081: osquery susceptible to DLL search order hijacking of zlib1.dll
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-07-10 · updated 2026-06-17
- Weakness: CWE-114
Description
osquery before version 4.4.0 enables a privilege escalation vulnerability. If a Window system is configured with a PATH that contains a user-writable directory then a local user may write a zlib1.dll DLL, which osquery will attempt to load. Since osquery runs with elevated privileges this enables local escalation. This is fixed in version 4.4.0.
Affected products
- osquery: before 4.4.0 — fixed in 4.4.0
How to fix
Upgrade to a fixed version: osquery 4.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/osquery/osquery/commit/4d4957f12a6aa0becc9d01d9f97061e1e3d809c5
- https://github.com/osquery/osquery/issues/6426
- https://github.com/osquery/osquery/pull/6433
- https://github.com/osquery/osquery/releases/tag/4.4.0
- https://github.com/osquery/osquery/security/advisories/GHSA-2xwp-8fv7-c5pm
- https://github.com/osquery/osquery/commit/4d4957f12a6aa0becc9d01d9f97061e1e3d809c5
- https://github.com/osquery/osquery/issues/6426
- https://github.com/osquery/osquery/pull/6433
- https://github.com/osquery/osquery/releases/tag/4.4.0
- https://github.com/osquery/osquery/security/advisories/GHSA-2xwp-8fv7-c5pm
Get alerted when CVE-2020-11081 or the next vulnerability affects your stack