What’s Vulnerable › Vulnerabilities
CVE-2020-11093: Authorization bypass in Hyperledger Indy
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-24 · updated 2026-06-17
- Weakness: CWE-347
Description
Hyperledger Indy Node is the server portion of a distributed ledger purpose-built for decentralized identity. In Hyperledger Indy before version 1.12.4, there is lack of signature verification on a specific transaction which enables an attacker to make certain unauthorized alterations to the ledger. Updating a DID with a nym transaction will be written to the ledger if neither ROLE or VERKEY are being changed, regardless of sender. A malicious DID with no particular role can ask an update for another DID (but cannot modify its verkey or role). This is bad because 1) Any DID can write a nym transaction to the ledger (i.e., any DID can spam the ledger with nym transactions), 2) Any DID can change any other DID's alias, 3) The update transaction modifies the ledger metadata associated with a DID.
Affected products
- hyperledger indy-node: before 1.12.4 — fixed in 1.12.4
How to fix
Upgrade to a fixed version: hyperledger indy-node 1.12.4. Check the vendor advisory for mitigations.
References
- https://github.com/hyperledger/indy-node/blob/master/CHANGELOG.md#1124
- https://github.com/hyperledger/indy-node/blob/master/docs/source/auth_rules.md
- https://github.com/hyperledger/indy-node/commit/55056f22c83b7c3520488b615e1577e0f895d75a
- https://github.com/hyperledger/indy-node/security/advisories/GHSA-wh2w-39f4-rpv2
- https://github.com/hyperledger/indy-node/blob/master/CHANGELOG.md#1124
- https://github.com/hyperledger/indy-node/blob/master/docs/source/auth_rules.md
- https://github.com/hyperledger/indy-node/commit/55056f22c83b7c3520488b615e1577e0f895d75a
- https://github.com/hyperledger/indy-node/security/advisories/GHSA-wh2w-39f4-rpv2
Get alerted when CVE-2020-11093 or the next vulnerability affects your stack