What’s Vulnerable › Vulnerabilities
CVE-2020-11107
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 22.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-04-02 · updated 2026-06-17
- Weakness: CWE-732
Description
An issue was discovered in XAMPP before 7.2.29, 7.3.x before 7.3.16 , and 7.4.x before 7.4.4 on Windows. An unprivileged user can change a .exe configuration in xampp-contol.ini for all users (including admins) to enable arbitrary command execution.
Affected products
- XAMPP: before 7.2.29; from 7.3.0 before 7.3.16; from 7.4.0 before 7.4.4 — fixed in 7.2.29, 7.3.16, 7.4.4
How to fix
Upgrade to a fixed version: XAMPP 7.2.29, 7.3.16, 7.4.4. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/164292/XAMPP-7.4.3-Privilege-Escalation.html
- https://www.apachefriends.org/blog/new_xampp_20200401.html
- http://packetstormsecurity.com/files/164292/XAMPP-7.4.3-Privilege-Escalation.html
- https://www.apachefriends.org/blog/new_xampp_20200401.html
Get alerted when CVE-2020-11107 or the next vulnerability affects your stack