What’s Vulnerable › Vulnerabilities
CVE-2020-11457
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-04-01 · updated 2026-06-17
- Weakness: CWE-79
Description
pfSense before 2.4.5 has stored XSS in system_usermanager_addprivs.php in the WebGUI via the descr parameter (aka full name) of a user.
Affected products
- Netgate pfSense: before 2.4.5 — fixed in 2.4.5
How to fix
Upgrade to a fixed version: Netgate pfSense 2.4.5. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/157104/pfSense-2.4.4-P3-User-Manager-Cross-Site-Scripting.html
- https://github.com/pfsense/pfsense/commit/3c1e53dabe966f27c9097a5a923e77f49ae5fffa
- https://www.exploit-db.com/exploits/48300
- https://www.netgate.com/assets/downloads/advisories/pfSense-SA-20_06.webgui.asc
- http://packetstormsecurity.com/files/157104/pfSense-2.4.4-P3-User-Manager-Cross-Site-Scripting.html
- https://github.com/pfsense/pfsense/commit/3c1e53dabe966f27c9097a5a923e77f49ae5fffa
- https://www.exploit-db.com/exploits/48300
- https://www.netgate.com/assets/downloads/advisories/pfSense-SA-20_06.webgui.asc
Get alerted when CVE-2020-11457 or the next vulnerability affects your stack