What’s Vulnerable › Vulnerabilities
CVE-2020-11501
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-03 · updated 2026-10-14
- Weakness: CWE-330
Description
GnuTLS 3.6.x before 3.6.13 uses incorrect cryptography for DTLS. The earliest affected version is 3.6.3 (2018-07-16) because of an error in a 2017-10-06 commit. The DTLS client always uses 32 '\0' bytes instead of a random value, and thus contributes no randomness to a DTLS negotiation. This breaks the security guarantees of the DTLS protocol.
Affected products
- Canonical Ubuntu Linux: 19.10
- Debian Linux: 10.0
- Fedoraproject Fedora: 31, 32
- [UNKNOWN] gnutls: from 3.6.3 before 3.6.13 — fixed in 3.6.13
- openSUSE Leap: 15.1
How to fix
Upgrade to a fixed version: [UNKNOWN] gnutls 3.6.13. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00015.html
- https://gitlab.com/gnutls/gnutls/-/commit/5b595e8e52653f6c5726a4cdd8fddeb6e83804d2
- https://gitlab.com/gnutls/gnutls/-/issues/960
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ILMOWPKMTZAIMK5F32TUMO34XCABUCFJ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WDYY3R4F5CUTFAMXH2C5NKYFVDEJLTT7/
- https://security.gentoo.org/glsa/202004-06
- https://security.netapp.com/advisory/ntap-20200416-0002/
- https://usn.ubuntu.com/4322-1/
- https://www.debian.org/security/2020/dsa-4652
- https://www.gnutls.org/security-new.html#GNUTLS-SA-2020-03-31
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00015.html
- https://gitlab.com/gnutls/gnutls/-/commit/5b595e8e52653f6c5726a4cdd8fddeb6e83804d2
Get alerted when CVE-2020-11501 or the next vulnerability affects your stack