What’s Vulnerable › Vulnerabilities
CVE-2020-11524
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-05-15 · updated 2026-06-17
- Weakness: CWE-787
Description
libfreerdp/codec/interleaved.c in FreeRDP versions > 1.0 through 2.0.0-rc4 has an Out-of-bounds Write.
Affected products
- Canonical Ubuntu Linux: 18.04, 19.10, 20.04
- FreeRDP: from 1.0.0 (excl.) before 2.0.0; 2.0.0, 2.0.0-rc0, 2.0.0-rc1, 2.0.0-rc2, 2.0.0-rc3, 2.0.0-rc4 — fixed in 2.0.0
- openSUSE Leap: 15.1
How to fix
Upgrade to a fixed version: FreeRDP 2.0.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00080.html
- https://github.com/FreeRDP/FreeRDP/commits/master
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-cgw8-3mp2-p5qw
- https://pub.freerdp.com/cve/CVE-2020-11524/pocAnalysis_3.pdf
- https://usn.ubuntu.com/4379-1/
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00080.html
- https://github.com/FreeRDP/FreeRDP/commits/master
- https://github.com/FreeRDP/FreeRDP/security/advisories/GHSA-cgw8-3mp2-p5qw
- https://pub.freerdp.com/cve/CVE-2020-11524/pocAnalysis_3.pdf
- https://usn.ubuntu.com/4379-1/
Get alerted when CVE-2020-11524 or the next vulnerability affects your stack