What’s Vulnerable › Vulnerabilities
CVE-2020-11653
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-08 · updated 2026-06-17
- Weakness: CWE-617
Description
An issue was discovered in Varnish Cache before 6.0.6 LTS, 6.1.x and 6.2.x before 6.2.3, and 6.3.x before 6.3.2. It occurs when communication with a TLS termination proxy uses PROXY version 2. There can be an assertion failure and daemon restart, which causes a performance loss.
Affected products
- Debian Linux: 10.0
- openSUSE Backports Sle: 15.0-sp1
- openSUSE Leap: 15.1
- Varnish-Cache Varnish Cache: from 6.1.0 before 6.2.3; from 6.3.0 before 6.3.2 — fixed in 6.2.3, 6.3.2
- varnish-software Varnish Cache: from 6.0.0 before 6.0.6 — fixed in 6.0.6
How to fix
Upgrade to a fixed version: Varnish-Cache Varnish Cache 6.2.3, 6.3.2; varnish-software Varnish Cache 6.0.6. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-06/msg00026.html
- http://lists.opensuse.org/opensuse-security-announce/2020-06/msg00031.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00036.html
- https://varnish-cache.org/security/VSV00005.html#vsv00005
- http://lists.opensuse.org/opensuse-security-announce/2020-06/msg00026.html
- http://lists.opensuse.org/opensuse-security-announce/2020-06/msg00031.html
- https://lists.debian.org/debian-lts-announce/2022/11/msg00036.html
- https://varnish-cache.org/security/VSV00005.html#vsv00005
Get alerted when CVE-2020-11653 or the next vulnerability affects your stack