What’s Vulnerable › Vulnerabilities
CVE-2020-11738: WordPress Snap Creek Duplicator Plugin File Download Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2021-11-03
- EPSS: 97.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-04-13 · updated 2026-06-17
- Weakness: CWE-22
Description
The Snap Creek Duplicator plugin before 1.3.28 for WordPress (and Duplicator Pro before 3.8.7.1) allows Directory Traversal via ../ in the file parameter to duplicator_download or duplicator_init.
Affected products
- Duplicator: before 1.3.28; before 3.8.7.1 — fixed in 1.3.28, 3.8.7.1
How to fix
Upgrade to a fixed version: Duplicator 1.3.28, 3.8.7.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/160621/WordPress-Duplicator-1.3.26-Directory-Traversal-File-Read.html
- http://packetstormsecurity.com/files/164533/WordPress-Duplicator-1.3.26-Arbitrary-File-Read.html
- https://cwe.mitre.org/data/definitions/23.html
- https://snapcreek.com/duplicator/docs/changelog/?lite
- https://www.wordfence.com/blog/2020/02/active-attack-on-recently-patched-duplicator-plugin-vulnerability-affects-over-1-million-sites/
- http://packetstormsecurity.com/files/160621/WordPress-Duplicator-1.3.26-Directory-Traversal-File-Read.html
- http://packetstormsecurity.com/files/164533/WordPress-Duplicator-1.3.26-Arbitrary-File-Read.html
- https://cwe.mitre.org/data/definitions/23.html
- https://snapcreek.com/duplicator/docs/changelog/?lite
- https://www.wordfence.com/blog/2020/02/active-attack-on-recently-patched-duplicator-plugin-vulnerability-affects-over-1-million-sites/
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2020-11738
Get alerted when CVE-2020-11738 or the next vulnerability affects your stack