What’s Vulnerable › Vulnerabilities
CVE-2020-11793
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-17 · updated 2026-06-17
- Weakness: CWE-416
Description
A use-after-free issue exists in WebKitGTK before 2.28.1 and WPE WebKit before 2.28.1 via crafted web content that allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash).
Affected products
- Canonical Ubuntu Linux: 18.04, 19.10
- Fedoraproject Fedora: 30, 31, 32
- openSUSE Leap: 15.1
- Webkit: before 2.28.1 — fixed in 2.28.1
- Wpewebkit Wpe Webkit: before 2.28.1 — fixed in 2.28.1
How to fix
Upgrade to a fixed version: Webkit 2.28.1; Wpewebkit Wpe Webkit 2.28.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00008.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3P4YISPE5QX4YD54GDRZIH2X5RCH3QGW/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/K3MQTRC6ITFTVS5R5Z24PMJS6FXJKGRD/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UTKY2MWP6PB6TE3ZKOOMKX7HZUCQNYF6/
- https://security.gentoo.org/glsa/202006-08
- https://usn.ubuntu.com/4331-1/
- https://webkitgtk.org/security/WSA-2020-0004.html
- https://wpewebkit.org/security/WSA-2020-0004.html
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00008.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3P4YISPE5QX4YD54GDRZIH2X5RCH3QGW/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/K3MQTRC6ITFTVS5R5Z24PMJS6FXJKGRD/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UTKY2MWP6PB6TE3ZKOOMKX7HZUCQNYF6/
Get alerted when CVE-2020-11793 or the next vulnerability affects your stack