What’s Vulnerable › Vulnerabilities
CVE-2020-11810
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-04-27 · updated 2026-06-17
- Weakness: CWE-362
Description
An issue was discovered in OpenVPN 2.4.x before 2.4.9. An attacker can inject a data channel v2 (P_DATA_V2) packet using a victim's peer-id. Normally such packets are dropped, but if this packet arrives before the data channel crypto parameters have been initialized, the victim's connection will be dropped. This requires careful timing due to the small time window (usually within a few seconds) between the victim client connection starting and the server PUSH_REPLY response back to the client. This attack will only work if Negotiable Cipher Parameters (NCP) is in use.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- Fedoraproject Fedora: 30, 32
- OpenVPN: from 2.4.0 before 2.4.9 — fixed in 2.4.9
How to fix
Upgrade to a fixed version: OpenVPN 2.4.9. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=1169925
- https://community.openvpn.net/openvpn/ticket/1272
- https://github.com/OpenVPN/openvpn/commit/37bc691e7d26ea4eb61a8a434ebd7a9ae76225ab
- https://lists.debian.org/debian-lts-announce/2022/05/msg00002.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FGHHV4YZANZW45KZTJJGVGPFMSXYRCKZ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JII7RYYYRBPQNEGGVSOXCM7JUZ43T3VH/
- https://patchwork.openvpn.net/patch/1079/
- https://security-tracker.debian.org/tracker/CVE-2020-11810
- https://bugzilla.suse.com/show_bug.cgi?id=1169925
- https://community.openvpn.net/openvpn/ticket/1272
- https://github.com/OpenVPN/openvpn/commit/37bc691e7d26ea4eb61a8a434ebd7a9ae76225ab
- https://lists.debian.org/debian-lts-announce/2022/05/msg00002.html
Get alerted when CVE-2020-11810 or the next vulnerability affects your stack