What’s Vulnerable › Vulnerabilities
CVE-2020-11957
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-09 · updated 2026-06-17
- Weakness: CWE-331
Description
The Bluetooth Low Energy implementation in Cypress PSoC Creator BLE 4.2 component versions before 3.64 generates a random number (Pairing Random) with significantly less entropy than the specified 128 bits during BLE pairing. This is the case for both authenticated and unauthenticated pairing with both LE Secure Connections as well as LE Legacy Pairing. A predictable or brute-forceable random number allows an attacker (in radio range) to perform a MITM attack during BLE pairing.
Affected products
- Cypress Psoc 4.2 Ble: before 3.64 — fixed in 3.64
How to fix
Upgrade to a fixed version: Cypress Psoc 4.2 Ble 3.64. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-11957 or the next vulnerability affects your stack