What’s Vulnerable › Vulnerabilities
CVE-2020-11975
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 30.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-06-05 · updated 2026-06-17
Description
Apache Unomi allows conditions to use OGNL scripting which offers the possibility to call static Java classes from the JDK that could execute code with the permission level of the running Java process.
Affected products
- Apache Software Foundation Apache Unomi: before 1.5.1 — fixed in 1.5.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Unomi 1.5.1. Check the vendor advisory for mitigations.
References
- http://unomi.apache.org/security/cve-2020-11975.txt
- https://lists.apache.org/thread.html/r01021bc4b25c1e98812efca0b07f0e078a6281bd52f7c3817a429d95%40%3Ccommits.unomi.apache.org%3E
- https://lists.apache.org/thread.html/r79672c25e0ef9bb4b9148376281200a8e61c6d5ef5bb705e9a363460%40%3Ccommits.unomi.apache.org%3E
- http://unomi.apache.org/security/cve-2020-11975.txt
- https://lists.apache.org/thread.html/r01021bc4b25c1e98812efca0b07f0e078a6281bd52f7c3817a429d95%40%3Ccommits.unomi.apache.org%3E
- https://lists.apache.org/thread.html/r79672c25e0ef9bb4b9148376281200a8e61c6d5ef5bb705e9a363460%40%3Ccommits.unomi.apache.org%3E
Get alerted when CVE-2020-11975 or the next vulnerability affects your stack