What’s Vulnerable › Vulnerabilities
CVE-2020-11977
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-09-15 · updated 2026-06-17
Description
In Apache Syncope 2.1.X releases prior to 2.1.7, when the Flowable extension is enabled, an administrator with workflow entitlements can use Shell Service Tasks to perform malicious operations, including but not limited to file read, file write, and code execution.
Affected products
- Apache Software Foundation Apache Syncope: from 2.1.0 before 2.1.7 — fixed in 2.1.7
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Syncope 2.1.7. Check the vendor advisory for mitigations.
References
- https://syncope.apache.org/security#CVE-2020-11977:_Remote_Code_Execution_via_Flowable_workflow_definition
- https://syncope.apache.org/security#CVE-2020-11977:_Remote_Code_Execution_via_Flowable_workflow_definition
Get alerted when CVE-2020-11977 or the next vulnerability affects your stack