What’s Vulnerable › Vulnerabilities
CVE-2020-12004
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 14.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-09 · updated 2026-06-17
- Weakness: CWE-306
Description
The affected product lacks proper authentication required to query the server on the Ignition 8 Gateway (versions prior to 8.0.10) and Ignition 7 Gateway (versions prior to 7.9.14), allowing an attacker to obtain sensitive information.
Affected products
- Ignition 8 Gateway: from 7.2.4.48 before 7.9.14; from 8.0 before 8.0.10 — fixed in 7.9.14, 8.0.10
How to fix
Upgrade to a fixed version: Ignition 8 Gateway 7.9.14, 8.0.10. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/158226/Inductive-Automation-Ignition-Remote-Code-Execution.html
- https://www.us-cert.gov/ics/advisories/icsa-20-147-01
- http://packetstormsecurity.com/files/158226/Inductive-Automation-Ignition-Remote-Code-Execution.html
- https://www.us-cert.gov/ics/advisories/icsa-20-147-01
Get alerted when CVE-2020-12004 or the next vulnerability affects your stack