What’s Vulnerable › Vulnerabilities
CVE-2020-12077
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-04-23 · updated 2026-06-17
- Weakness: CWE-434
Description
The mappress-google-maps-for-wordpress plugin before 2.53.9 for WordPress does not correctly implement AJAX functions with nonces (or capability checks), leading to remote code execution.
Affected products
- MapPress Maps for WordPress: before 2.53.9 — fixed in 2.53.9
How to fix
Upgrade to a fixed version: MapPress Maps for WordPress 2.53.9. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/mappress-google-maps-for-wordpress/#developers
- https://www.wordfence.com/blog/2020/04/critical-vulnerabilities-patched-in-mappress-maps-plugin/
- https://wordpress.org/plugins/mappress-google-maps-for-wordpress/#developers
- https://www.wordfence.com/blog/2020/04/critical-vulnerabilities-patched-in-mappress-maps-plugin/
Get alerted when CVE-2020-12077 or the next vulnerability affects your stack