What’s Vulnerable › Vulnerabilities
CVE-2020-12108
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-05-06 · updated 2026-06-17
- Weakness: CWE-74
Description
/options/mailman in GNU Mailman before 2.1.31 allows Arbitrary Content Injection.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04
- Debian Linux: 9.0, 10.0
- Fedoraproject Fedora: 31
- GNU Mailman: before 2.1.31 — fixed in 2.1.31
- openSUSE Backports Sle: 15.0-sp1, 15.0-sp2
- openSUSE Leap: 15.1, 15.2
How to fix
Upgrade to a fixed version: GNU Mailman 2.1.31. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-05/msg00036.html
- http://lists.opensuse.org/opensuse-security-announce/2020-06/msg00003.html
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00047.html
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00063.html
- https://bugs.launchpad.net/mailman/+bug/1873722
- https://code.launchpad.net/mailman
- https://lists.debian.org/debian-lts-announce/2020/05/msg00007.html
- https://lists.debian.org/debian-lts-announce/2020/07/msg00007.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/74EQIVFB34Q4UYAQLCUWG55YLKAUWCHD/
- https://mail.python.org/pipermail/mailman-announce/
- https://usn.ubuntu.com/4354-1/
- https://www.debian.org/security/2021/dsa-4991
Get alerted when CVE-2020-12108 or the next vulnerability affects your stack