What’s Vulnerable › Vulnerabilities
CVE-2020-12114
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-04 · updated 2026-06-17
- Weakness: CWE-362
Description
A pivot_root race condition in fs/namespace.c in the Linux kernel 4.4.x before 4.4.221, 4.9.x before 4.9.221, 4.14.x before 4.14.178, 4.19.x before 4.19.119, and 5.x before 5.3 allows local users to cause a denial of service (panic) by corrupting a mountpoint reference counter.
Affected products
- Linux kernel: from 4.4.0 before 4.4.221; from 4.9.0 before 4.9.221; from 4.14 before 4.14.178; from 4.19 before 4.19.119; from 5.0 before 5.3 — fixed in 4.14.178, 4.19.119, 4.4.221, 4.9.221, 5.3
How to fix
Upgrade to a fixed version: Linux kernel 4.14.178, 4.19.119, 4.4.221, 4.9.221. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-06/msg00022.html
- http://packetstormsecurity.com/files/159565/Kernel-Live-Patch-Security-Notice-LSN-0072-1.html
- http://www.openwall.com/lists/oss-security/2020/05/04/2
- https://lists.debian.org/debian-lts-announce/2020/06/msg00011.html
- https://lists.debian.org/debian-lts-announce/2020/06/msg00012.html
- https://lists.debian.org/debian-lts-announce/2020/06/msg00013.html
- https://security.netapp.com/advisory/ntap-20200608-0001/
- https://usn.ubuntu.com/4387-1/
- https://usn.ubuntu.com/4388-1/
- https://usn.ubuntu.com/4389-1/
- https://usn.ubuntu.com/4390-1/
- https://usn.ubuntu.com/4391-1/
Get alerted when CVE-2020-12114 or the next vulnerability affects your stack