What’s Vulnerable › Vulnerabilities
CVE-2020-12145: Silver Peak Unity OrchestratorTM authentication can be subverted through manipulation of HTTP headers.
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-05 · updated 2026-06-17
- Weakness: CWE-287
Description
Silver Peak Unity Orchestrator versions prior to 8.9.11+, 8.10.11+, or 9.0.1+ uses HTTP headers to authenticate REST API calls from localhost. This makes it possible to log in to Orchestrator by introducing an HTTP HOST header set to 127.0.0.1 or localhost. Orchestrator instances that are hosted by customers –on-premise or in a public cloud provider –are affected by this vulnerability.
Affected products
- Silver Peak Systems, Inc. Unity Orchestrator: before 8.9.11\+; from 8.10 before 8.10.11\+; from 9.0 before 9.0.1\+ — fixed in 8.10.11\+, 8.9.11\+, 9.0.1\+
How to fix
Upgrade to a fixed version: Silver Peak Systems, Inc. Unity Orchestrator 8.10.11\+, 8.9.11\+, 9.0.1\+. Check the vendor advisory for mitigations.
References
- https://www.silver-peak.com/support/user-documentation/security-advisories
- https://www.silver-peak.com/support/user-documentation/security-advisories
Get alerted when CVE-2020-12145 or the next vulnerability affects your stack