What’s Vulnerable › Vulnerabilities
CVE-2020-12265
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-04-26 · updated 2026-06-17
- Weakness: CWE-22
Description
The decompress package before 4.2.1 for Node.js is vulnerable to Arbitrary File Write via ../ in an archive member, when a symlink is used, because of Directory Traversal.
Affected products
- Decompress Project Decompress: before 4.2.1 — fixed in 4.2.1
How to fix
Upgrade to a fixed version: Decompress Project Decompress 4.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/kevva/decompress/issues/71
- https://github.com/kevva/decompress/pull/73
- https://www.npmjs.com/advisories/1217
- https://github.com/kevva/decompress/issues/71
- https://github.com/kevva/decompress/pull/73
- https://www.npmjs.com/advisories/1217
Get alerted when CVE-2020-12265 or the next vulnerability affects your stack