What’s Vulnerable › Vulnerabilities
CVE-2020-12351
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-11-23 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper input validation in BlueZ may allow an unauthenticated user to potentially enable escalation of privilege via adjacent access.
Affected products
- Linux kernel: from 4.7.7 before 4.9.240; from 4.10 before 4.14.202; from 4.15 before 4.19.152; from 4.20 before 5.4.72; from 5.5 before 5.8.16; 5.9.0, 5.9.0-rc1, 5.9.0-rc2, 5.9.0-rc3, 5.9.0-rc4, 5.9.0-rc5 (+2) — fixed in 4.14.202, 4.19.152, 4.9.240, 5.4.72, 5.8.16
How to fix
Upgrade to a fixed version: Linux kernel 4.14.202, 4.19.152, 4.9.240, 5.4.72. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/162131/Linux-Kernel-5.4-BleedingTooth-Remote-Code-Execution.html
- https://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00435.html?wapkw=CVE-2020-12351
- http://packetstormsecurity.com/files/162131/Linux-Kernel-5.4-BleedingTooth-Remote-Code-Execution.html
- https://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00435.html?wapkw=CVE-2020-12351
Get alerted when CVE-2020-12351 or the next vulnerability affects your stack