What’s Vulnerable › Vulnerabilities
CVE-2020-12416
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-07-09 · updated 2026-06-17
- Weakness: CWE-362
Description
A VideoStreamEncoder may have been freed in a race condition with VideoBroadcaster::AddOrUpdateSink, resulting in a use-after-free, memory corruption, and a potentially exploitable crash. This vulnerability affects Firefox < 78.
Affected products
- Mozilla Firefox: before 78.0 — fixed in 78.0
- openSUSE Leap: 15.1, 15.2
How to fix
Upgrade to a fixed version: Mozilla Firefox 78.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00027.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00049.html
- https://bugzilla.mozilla.org/show_bug.cgi?id=1639734
- https://security.gentoo.org/glsa/202007-10
- https://www.mozilla.org/security/advisories/mfsa2020-24/
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00027.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00049.html
- https://bugzilla.mozilla.org/show_bug.cgi?id=1639734
- https://security.gentoo.org/glsa/202007-10
- https://www.mozilla.org/security/advisories/mfsa2020-24/
Get alerted when CVE-2020-12416 or the next vulnerability affects your stack