What’s Vulnerable › Vulnerabilities
CVE-2020-12418
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-09 · updated 2026-06-17
- Weakness: CWE-125
Description
Manipulating individual parts of a URL object could have caused an out-of-bounds read, leaking process memory to malicious JavaScript. This vulnerability affects Firefox ESR < 68.10, Firefox < 78, and Thunderbird < 68.10.0.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 19.10, 20.04
- Mozilla Firefox: before 78.0 — fixed in 78.0
- Mozilla Firefox ESR: before 68.10 — fixed in 68.10
- Mozilla Thunderbird: before 68.10.0 — fixed in 68.10.0
- openSUSE Leap: 15.1, 15.2
How to fix
Upgrade to a fixed version: Mozilla Firefox 78.0; Mozilla Firefox ESR 68.10; Mozilla Thunderbird 68.10.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00023.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00026.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00027.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00049.html
- https://bugzilla.mozilla.org/show_bug.cgi?id=1641303
- https://security.gentoo.org/glsa/202007-09
- https://security.gentoo.org/glsa/202007-10
- https://usn.ubuntu.com/4421-1/
- https://www.mozilla.org/security/advisories/mfsa2020-24/
- https://www.mozilla.org/security/advisories/mfsa2020-25/
- https://www.mozilla.org/security/advisories/mfsa2020-26/
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00023.html
Get alerted when CVE-2020-12418 or the next vulnerability affects your stack