What’s Vulnerable › Vulnerabilities
CVE-2020-12422
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-09 · updated 2026-06-17
- Weakness: CWE-787
Description
In non-standard configurations, a JPEG image created by JavaScript could have caused an internal variable to overflow, resulting in an out of bounds write, memory corruption, and a potentially exploitable crash. This vulnerability affects Firefox < 78.
Affected products
- Mozilla Firefox: before 78.0 — fixed in 78.0
- openSUSE Leap: 15.1, 15.2
How to fix
Upgrade to a fixed version: Mozilla Firefox 78.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00027.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00049.html
- https://bugzilla.mozilla.org/show_bug.cgi?id=1450353
- https://security.gentoo.org/glsa/202007-10
- https://www.mozilla.org/security/advisories/mfsa2020-24/
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00027.html
- http://lists.opensuse.org/opensuse-security-announce/2020-07/msg00049.html
- https://bugzilla.mozilla.org/show_bug.cgi?id=1450353
- https://security.gentoo.org/glsa/202007-10
- https://www.mozilla.org/security/advisories/mfsa2020-24/
Get alerted when CVE-2020-12422 or the next vulnerability affects your stack