What’s Vulnerable › Vulnerabilities
CVE-2020-12517: Phoenix Contact PLCnext Control Devices versions before 2021.0 LTS: An authenticated low privileged user could embed malicious Javascript code to gain admin rights when the admin user visits the vulnerable website (local privilege escalation).
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-17 · updated 2026-06-17
- Weakness: CWE-79
Description
On Phoenix Contact PLCnext Control Devices versions before 2021.0 LTS an authenticated low privileged user could embed malicious Javascript code to gain admin rights when the admin user visits the vulnerable website (local privilege escalation).
Affected products
- Phoenixcontact Plcnext Firmware: before 2021.0 — fixed in 2021.0
How to fix
Upgrade to a fixed version: Phoenixcontact Plcnext Firmware 2021.0. Check the vendor advisory for mitigations.
References
- https://cert.vde.com/en-us/advisories/vde-2020-049
- https://cert.vde.com/en-us/advisories/vde-2020-049
Get alerted when CVE-2020-12517 or the next vulnerability affects your stack