What’s Vulnerable › Vulnerabilities
CVE-2020-12519: Phoenix Contact PLCnext Control Devices versions before 2021.0 LTS: An attacker can use this vulnerability i.e. to open a reverse shell with root privileges.
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-17 · updated 2026-06-17
- Weakness: CWE-269
Description
On Phoenix Contact PLCnext Control Devices versions before 2021.0 LTS an attacker can use this vulnerability i.e. to open a reverse shell with root privileges.
Affected products
- Phoenixcontact Plcnext Firmware: before 2021.0 — fixed in 2021.0
How to fix
Upgrade to a fixed version: Phoenixcontact Plcnext Firmware 2021.0. Check the vendor advisory for mitigations.
References
- https://cert.vde.com/en-us/advisories/vde-2020-049
- https://cert.vde.com/en-us/advisories/vde-2020-049
Get alerted when CVE-2020-12519 or the next vulnerability affects your stack