What’s Vulnerable › Vulnerabilities
CVE-2020-12620
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-07-30 · updated 2026-06-17
- Weakness: CWE-78
Description
Pi-hole 4.4 allows a user able to write to /etc/pihole/dns-servers.conf to escalate privileges through command injection (shell metacharacters after an IP address).
Affected products
- pi-hole: before 5.0 — fixed in 5.0
How to fix
Upgrade to a fixed version: pi-hole 5.0. Check the vendor advisory for mitigations.
References
- https://0xpanic.github.io/2020/07/21/Pihole.html
- https://github.com/pi-hole/pi-hole
- https://pi-hole.net/
- https://0xpanic.github.io/2020/07/21/Pihole.html
- https://github.com/pi-hole/pi-hole
- https://pi-hole.net/
Get alerted when CVE-2020-12620 or the next vulnerability affects your stack