What’s Vulnerable › Vulnerabilities
CVE-2020-12647
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-21 · updated 2026-06-17
Description
Unisys ALGOL Compiler 58.1 before 58.1a.15, 59.1 before 59.1a.9, and 60.0 before 60.0a.5 can emit invalid code sequences under rare circumstances related to syntax. The resulting code could, for example, trigger a system fault or adversely affect confidentiality, integrity, and availability.
Affected products
- Unisys Algol Compiler: from 58.1 before 58.1a.15; from 59.1 before 59.1a.9; from 60.0 before 60.0a.5 — fixed in 58.1a.15, 59.1a.9, 60.0a.5
How to fix
Upgrade to a fixed version: Unisys Algol Compiler 58.1a.15, 59.1a.9, 60.0a.5. Check the vendor advisory for mitigations.
References
- https://public.support.unisys.com/common/public/vulnerability/NVD_Detail_Rpt.aspx?ID=55
- https://public.support.unisys.com/common/public/vulnerability/NVD_Detail_Rpt.aspx?ID=55
Get alerted when CVE-2020-12647 or the next vulnerability affects your stack