What’s Vulnerable › Vulnerabilities
CVE-2020-12651
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-05-15 · updated 2026-06-17
- Weakness: CWE-190
Description
SecureCRT before 8.7.2 allows remote attackers to execute arbitrary code via an Integer Overflow and a Buffer Overflow because a banner can trigger a line number to CSI functions that exceeds INT_MAX.
Affected products
- Vandyke Securecrt: before 8.7.2; before 2.4 — fixed in 2.4, 8.7.2
How to fix
Upgrade to a fixed version: Vandyke Securecrt 2.4, 8.7.2. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/project-zero/issues/detail?id=2033
- https://twitter.com/taviso/status/1261079774190919680
- https://www.vandyke.com/products/securecrt/history.txt
- https://www.vandyke.com/support/advisory/index.html
- https://bugs.chromium.org/p/project-zero/issues/detail?id=2033
- https://twitter.com/taviso/status/1261079774190919680
- https://www.vandyke.com/products/securecrt/history.txt
- https://www.vandyke.com/support/advisory/index.html
Get alerted when CVE-2020-12651 or the next vulnerability affects your stack