What’s Vulnerable › Vulnerabilities
CVE-2020-12654
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-05 · updated 2026-06-17
- Weakness: CWE-787
Description
An issue was found in Linux kernel before 5.5.4. mwifiex_ret_wmm_get_status() in drivers/net/wireless/marvell/mwifiex/wmm.c allows a remote AP to trigger a heap-based buffer overflow because of an incorrect memcpy, aka CID-3a9b153c5591.
Affected products
- Linux kernel: before 5.5.4 — fixed in 5.5.4
How to fix
Upgrade to a fixed version: Linux kernel 5.5.4. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-06/msg00022.html
- http://www.openwall.com/lists/oss-security/2020/05/08/2
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.5.4
- https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=3a9b153c5591548612c3955c9600a98150c81875
- https://github.com/torvalds/linux/commit/3a9b153c5591548612c3955c9600a98150c81875
- https://lists.debian.org/debian-lts-announce/2020/06/msg00011.html
- https://lists.debian.org/debian-lts-announce/2020/06/msg00012.html
- https://lists.debian.org/debian-lts-announce/2020/06/msg00013.html
- https://security.netapp.com/advisory/ntap-20200608-0001/
- https://usn.ubuntu.com/4392-1/
- https://usn.ubuntu.com/4393-1/
- https://www.debian.org/security/2020/dsa-4698
Get alerted when CVE-2020-12654 or the next vulnerability affects your stack