What’s Vulnerable › Vulnerabilities
CVE-2020-12658
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-31 · updated 2026-06-17
- Weakness: CWE-667
Description
gssproxy (aka gss-proxy) before 0.8.3 does not unlock cond_mutex before pthread exit in gp_worker_main() in gp_workers.c. NOTE: An upstream comment states "We are already on a shutdown path when running the code in question, so a DoS there doesn't make any sense, and there has been no additional information provided us (as upstream) to indicate why this would be a problem.
Affected products
- Debian Linux: 9.0
- Gssproxy Project Gssproxy: before 0.8.3 — fixed in 0.8.3
How to fix
Upgrade to a fixed version: Gssproxy Project Gssproxy 0.8.3. Check the vendor advisory for mitigations.
References
- https://github.com/gssapi/gssproxy/commit/cb761412e299ef907f22cd7c4146d50c8a792003
- https://github.com/gssapi/gssproxy/compare/v0.8.2...v0.8.3
- https://lists.debian.org/debian-lts-announce/2021/01/msg00004.html
- https://pagure.io/gssproxy/c/cb761412e299ef907f22cd7c4146d50c8a792003?branch=master
- https://github.com/gssapi/gssproxy/commit/cb761412e299ef907f22cd7c4146d50c8a792003
- https://github.com/gssapi/gssproxy/compare/v0.8.2...v0.8.3
- https://lists.debian.org/debian-lts-announce/2021/01/msg00004.html
- https://pagure.io/gssproxy/c/cb761412e299ef907f22cd7c4146d50c8a792003?branch=master
Get alerted when CVE-2020-12658 or the next vulnerability affects your stack