What’s Vulnerable › Vulnerabilities
CVE-2020-12674
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-08-12 · updated 2026-06-17
- Weakness: CWE-125
Description
In Dovecot before 2.3.11.3, sending a specially formatted RPA request will crash the auth service because a length of zero is mishandled.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 20.04
- Debian Linux: 9.0, 10.0
- dovecot: before 2.3.11.3 — fixed in 2.3.11.3
- Fedoraproject Fedora: 31, 32, 33
How to fix
Upgrade to a fixed version: dovecot 2.3.11.3. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00048.html
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00059.html
- https://dovecot.org/security
- https://lists.debian.org/debian-lts-announce/2020/08/msg00024.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4AAX2MJEULPVSRZOBX3PNPFSYP4FM4TT/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/EYZU6CHA3VMYYAUCMHSCCQKJEVEIKPQ2/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XKKAL3OMG76ZZ7CIEMQP2K6KCTD2RAKE/
- https://security.gentoo.org/glsa/202009-02
- https://usn.ubuntu.com/4456-1/
- https://usn.ubuntu.com/4456-2/
- https://www.debian.org/security/2020/dsa-4745
- https://www.openwall.com/lists/oss-security/2020/08/12/3
Get alerted when CVE-2020-12674 or the next vulnerability affects your stack