What’s Vulnerable › Vulnerabilities
CVE-2020-12675
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-29 · updated 2026-06-17
- Weakness: CWE-434
Description
The mappress-google-maps-for-wordpress plugin before 2.54.6 for WordPress does not correctly implement capability checks for AJAX functions related to creation/retrieval/deletion of PHP template files, leading to Remote Code Execution. NOTE: this issue exists because of an incomplete fix for CVE-2020-12077.
Affected products
- MapPress Maps for WordPress: before 2.54.6 — fixed in 2.54.6
How to fix
Upgrade to a fixed version: MapPress Maps for WordPress 2.54.6. Check the vendor advisory for mitigations.
References
- https://blog.alertlogic.com/alert-logic-threat-research-team-identifies-new-vulnerability-cve-2020-12675-in-mappress-plugin-for-wordpress/
- https://wordpress.org/plugins/mappress-google-maps-for-wordpress/#developers
- https://blog.alertlogic.com/alert-logic-threat-research-team-identifies-new-vulnerability-cve-2020-12675-in-mappress-plugin-for-wordpress/
- https://wordpress.org/plugins/mappress-google-maps-for-wordpress/#developers
Get alerted when CVE-2020-12675 or the next vulnerability affects your stack