What’s Vulnerable › Vulnerabilities
CVE-2020-12802: remote graphics contained in docx format retrieved in 'stealth mode'
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-08 · updated 2026-06-17
- Weakness: CWE-200
Description
LibreOffice has a 'stealth mode' in which only documents from locations deemed 'trusted' are allowed to retrieve remote resources. This mode is not the default mode, but can be enabled by users who want to disable LibreOffice's ability to include remote resources within a document. A flaw existed where remote graphic links loaded from docx documents were omitted from this protection prior to version 6.4.4. This issue affects: The Document Foundation LibreOffice versions prior to 6.4.4.
Affected products
- Fedoraproject Fedora: 31
- The Document Foundation LibreOffice: before 6.4.4 — fixed in 6.4.4
- openSUSE Leap: 15.1, 15.2
How to fix
Upgrade to a fixed version: The Document Foundation LibreOffice 6.4.4. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00042.html
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00058.html
- https://lists.debian.org/debian-lts-announce/2023/12/msg00026.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PQIBAKXD7VO5IGBD7ZMH3GGBNR5R2IOA/
- https://www.libreoffice.org/about-us/security/advisories/CVE-2020-12802
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00042.html
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00058.html
- https://lists.debian.org/debian-lts-announce/2023/12/msg00026.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/PQIBAKXD7VO5IGBD7ZMH3GGBNR5R2IOA/
- https://www.libreoffice.org/about-us/security/advisories/CVE-2020-12802
Get alerted when CVE-2020-12802 or the next vulnerability affects your stack