What’s Vulnerable › Vulnerabilities
CVE-2020-12863
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-06-24 · updated 2026-06-17
- Weakness: CWE-125
Description
An out-of-bounds read in SANE Backends before 1.0.30 may allow a malicious device connected to the same local network as the victim to read important information, such as the ASLR offsets of the program, aka GHSL-2020-083.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 20.04
- Debian Linux: 9.0
- openSUSE Leap: 15.1, 15.2
- Sane-Project Sane Backends: before 1.0.30 — fixed in 1.0.30
How to fix
Upgrade to a fixed version: Sane-Project Sane Backends 1.0.30. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00079.html
- http://lists.opensuse.org/opensuse-security-announce/2020-11/msg00003.html
- https://alioth-lists.debian.net/pipermail/sane-announce/2020/000041.html
- https://lists.debian.org/debian-lts-announce/2020/08/msg00029.html
- https://lists.debian.org/debian-lts-announce/2020/10/msg00010.html
- https://securitylab.github.com/advisories/GHSL-2020-075-libsane
- https://usn.ubuntu.com/4470-1/
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00079.html
- http://lists.opensuse.org/opensuse-security-announce/2020-11/msg00003.html
- https://alioth-lists.debian.net/pipermail/sane-announce/2020/000041.html
- https://lists.debian.org/debian-lts-announce/2020/08/msg00029.html
- https://lists.debian.org/debian-lts-announce/2020/10/msg00010.html
Get alerted when CVE-2020-12863 or the next vulnerability affects your stack