What’s Vulnerable › Vulnerabilities
CVE-2020-13322
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-09-30 · updated 2026-06-17
- Weakness: CWE-863
Description
A vulnerability was discovered in GitLab versions after 12.9. Due to improper verification of permissions, an unauthorized user can create and delete deploy tokens.
Affected products
- GitLab: from 12.9.0 before 12.10.13; from 13.0.0 before 13.0.8; from 13.1.0 before 13.1.2 — fixed in 12.10.13, 13.0.8, 13.1.2
How to fix
Upgrade to a fixed version: GitLab 12.10.13, 13.0.8, 13.1.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2020/CVE-2020-13322.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/212469
- https://gitlab.com/gitlab-org/cves/-/blob/master/2020/CVE-2020-13322.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/212469
Get alerted when CVE-2020-13322 or the next vulnerability affects your stack