What’s Vulnerable › Vulnerabilities
CVE-2020-13329
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-09-30 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue has been discovered in GitLab affecting versions from 12.6.2 prior to 12.10.13. GitLab was vulnerable to a stored XSS by in the blob view feature.
Affected products
- GitLab: before 12.6.2; from 12.10.0 before 12.10.13 — fixed in 12.10.13, 12.6.2
How to fix
Upgrade to a fixed version: GitLab 12.10.13, 12.6.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2020/CVE-2020-13329.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/208685
- https://gitlab.com/gitlab-org/cves/-/blob/master/2020/CVE-2020-13329.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/208685
Get alerted when CVE-2020-13329 or the next vulnerability affects your stack