What’s Vulnerable › Vulnerabilities

CVE-2020-13351

Description

Insufficient permission checks in scheduled pipeline API in GitLab CE/EE 13.0+ allows an attacker to read variable names and values for scheduled pipelines on projects visible to the attacker. Affected versions are >=13.0, <13.3.9,>=13.4.0, <13.4.5,>=13.5.0, <13.5.2.

Affected products

How to fix

Upgrade to a fixed version: GitLab 13.3.9, 13.4.5, 13.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2020-13351 or the next vulnerability affects your stack