What’s Vulnerable › Vulnerabilities
CVE-2020-13388
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-05-22 · updated 2026-06-17
- Weakness: CWE-78
Description
An exploitable vulnerability exists in the configuration-loading functionality of the jw.util package before 2.3 for Python. When loading a configuration with FromString or FromStream with YAML, one can execute arbitrary Python code, resulting in OS command execution, because safe_load is not used.
Affected products
- Python Jw.Util: before 2.3 — fixed in 2.3
How to fix
Upgrade to a fixed version: Python Jw.Util 2.3. Check the vendor advisory for mitigations.
References
- https://joel-malwarebenchmark.github.io
- https://joel-malwarebenchmark.github.io/blog/2020/04/27/cve-2020-13388-jw-util-vulnerability/
- https://security.netapp.com/advisory/ntap-20200528-0002/
- https://joel-malwarebenchmark.github.io
- https://joel-malwarebenchmark.github.io/blog/2020/04/27/cve-2020-13388-jw-util-vulnerability/
- https://security.netapp.com/advisory/ntap-20200528-0002/
Get alerted when CVE-2020-13388 or the next vulnerability affects your stack