What’s Vulnerable › Vulnerabilities
CVE-2020-13443
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-06-24 · updated 2026-06-17
- Weakness: CWE-434
Description
ExpressionEngine before 5.3.2 allows remote attackers to upload and execute arbitrary code in a .php%20 file via Compose Msg, Add attachment, and Save As Draft actions. A user with low privileges (member) is able to upload this. It is possible to bypass the MIME type check and file-extension check while uploading new files. Short aliases are not used for an attachment; instead, direct access is allowed to the uploaded files. It is possible to upload PHP only if one has member access, or registration/forum is enabled and one can create a member with the default group id of 5. To exploit this, one must to be able to send and compose messages (at least).
Affected products
- ExpressionEngine: before 5.3.2 — fixed in 5.3.2
How to fix
Upgrade to a fixed version: ExpressionEngine 5.3.2. Check the vendor advisory for mitigations.
References
- https://expressionengine.com/blog
- https://gist.github.com/mariuszpoplwski/51604d8a6d7d78fffdf590c25e844e09
- https://expressionengine.com/blog
- https://gist.github.com/mariuszpoplwski/51604d8a6d7d78fffdf590c25e844e09
Get alerted when CVE-2020-13443 or the next vulnerability affects your stack