What’s Vulnerable › Vulnerabilities
CVE-2020-13642
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-05-28 · updated 2026-06-17
- Weakness: CWE-352
Description
An issue was discovered in the SiteOrigin Page Builder plugin before 2.10.16 for WordPress. The action_builder_content function did not do any nonce verification, allowing for requests to be forged on behalf of an administrator. The panels_data $_POST variable allows for malicious JavaScript to be executed in the victim's browser.
Affected products
- gpriday Page Builder by SiteOrigin: before 2.10.16 — fixed in 2.10.16
How to fix
Upgrade to a fixed version: gpriday Page Builder by SiteOrigin 2.10.16. Check the vendor advisory for mitigations.
References
- https://wordpress.org/plugins/siteorigin-panels/#developers
- https://www.wordfence.com/blog/2020/05/vulnerabilities-patched-in-page-builder-by-siteorigin-affects-over-1-million-sites/
- https://wordpress.org/plugins/siteorigin-panels/#developers
- https://www.wordfence.com/blog/2020/05/vulnerabilities-patched-in-page-builder-by-siteorigin-affects-over-1-million-sites/
Get alerted when CVE-2020-13642 or the next vulnerability affects your stack