What’s Vulnerable › Vulnerabilities
CVE-2020-13664
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-05 · updated 2026-06-17
- Weakness: CWE-77
Description
Arbitrary PHP code execution vulnerability in Drupal Core under certain circumstances. An attacker could trick an administrator into visiting a malicious site that could result in creating a carefully named directory on the file system. With this directory in place, an attacker could attempt to brute force a remote code execution vulnerability. Windows servers are most likely to be affected. This issue affects: Drupal Drupal Core 8.8.x versions prior to 8.8.8; 8.9.x versions prior to 8.9.1; 9.0.1 versions prior to 9.0.1.
Affected products
- Drupal: from 8.8.0 before 8.8.8; from 8.9.0 before 8.9.1; from 9.0.0 before 9.0.1 — fixed in 8.8.8, 8.9.1, 9.0.1
How to fix
Upgrade to a fixed version: Drupal 8.8.8, 8.9.1, 9.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2020-13664 or the next vulnerability affects your stack